Tower Portal Inaccessible, Service Disruption with Orders
Incident Report for Betterview
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 15:43 UTC
Update
We are continuing to investigate this issue.
Posted Apr 26, 2024 - 15:43 UTC
Investigating
We are currently investigating this issue.
Posted Apr 26, 2024 - 15:32 UTC
This incident affected: Web (Tower Client Portal, One-Off Orders).