Intermittent Connection Issues to tower.betterview.com
Incident Report for Betterview
Resolved
The pattern of activity in our systems that was causing the connection issues has been seen a number of times since rolling out the fix. Access to tower.betterview.com has remained stable on each occurrence which validates the fix was effective.
Posted Sep 17, 2021 - 23:54 UTC
Monitoring
The fix to correct the cause of the intermittent connectivity to tower.betterview.com has been deployed. We will be monitoring to ensure that it the fix is effective.
Posted Sep 17, 2021 - 23:25 UTC
Identified
We have found the cause of the intermittent connectivity issues and have a fix staged for release to resolve the intermittent connectivity to tower.betterview.com.
Posted Sep 17, 2021 - 20:37 UTC
Investigating
We are currently investigating this issue.
Posted Sep 17, 2021 - 18:51 UTC
This incident affected: Web (Tower Client Portal).