Elevated Authentication Errors
Incident Report for Betterview
Resolved
A fix has been deployed and confirmed to be working. We have been monitoring the state of our systems and are confident the issue that began this morning has been resolved.
Posted Jan 19, 2022 - 02:15 UTC
Monitoring
An interim fix is in place while we work on rolling out a more permanent remediation. At this time, services are accessible and working without error. We will update once the permanent fix has been fully deployed.
Posted Jan 18, 2022 - 22:29 UTC
Identified
We've identified the issue and are preparing a fix that we believe will correct the problem.
Posted Jan 18, 2022 - 22:12 UTC
Update
This is an update that we're continuing to investigate the cause of the errors we're seeing on tower.betterview.com. We will continue to provide updates here.
Posted Jan 18, 2022 - 21:35 UTC
Investigating
We are currently investigating an issue in which logins to tower.betterview.com are failing. Some users may be logged into the site but unable to access its functionalities. This is believed to be a side effect of the errors being experienced with authentication. We are working to confirm as we track down the cause of this issue.
Posted Jan 18, 2022 - 20:36 UTC
This incident affected: Web (Tower Client Portal).