User permissions issue
Incident Report for Betterview
Resolved
The fix for this issue has been promoted to production and validated working.
Posted Sep 09, 2021 - 17:30 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 09, 2021 - 15:24 UTC
Investigating
We are currently investigating an issue with access that may prevent some users from interacting with the system. Users may see messages that they cannot place orders due to view only access.
Posted Sep 09, 2021 - 14:53 UTC
This incident affected: Web (Tower Client Portal).